How do I troubleshoot VMDK file not found errors?

Issue

On attempting to pair a server by using a hypervisor connection with your Datto backup appliance, or when trying to perform a backup of a system protected with the agentless backup solution, you receive the error message, "Critical backup failure: VMDK file not found: /home/agents/vm-vmname/vm.vmdk. Check if VM mount succeeded."

Environment

  • Datto SIRIS
  • Agentless backups

Cause

These failures apply to agentless backups and can be caused by ESXi failing to resolve a VM's address by hostname. Finding the VM is the first step in the backup process. The vddk-fuse process then mounts the snapshot from the VMWare environment for network transfer to the Datto device.

Attaching independent disks to the VM may also cause this error. Independent disks are not affected by VMware snapshots, and the VMDK 'file not found' error can occur during pairing.

If the datastore name in VMware contains non-ASCII characters, agents may fail to pair with this error.

Resolution

To resolve this error, make sure that there is an internal DNS entry on the Configure > Networking tab of the Datto appliance GUI.


Figure 1: Configure > Networking

Make sure that internal DNS entries appear above the public entries.


Figure 2: DNS Servers

If the agent contains non-ASCII characters, rename it to remove them.

If you are still unable to pair the protected agent or resume backups, add the Datto device to your domain via the Configure > Networking tab of the GUI. Then, test communication to the target VM again. This test allows you to confirm that internal DNS troubleshooting is necessary; you should not leave the >device on the domain after troubleshooting.