Datto Windows Agent: Error Reading from Snapshot. Error: 21

Issue

When you try to start a backup with the Datto Windows Agent, you receive the error message "Error Reading from Snapshot. Error: 21."

Environment

  • Datto Windows Agent

Cause

Error: 21 is a Windows error code denoting that the specified device is not ready. Common causes are:

  • Disk errors
  • Filesystem errors
  • Insufficient free space on the affected disk of protected system
  • Insufficient available RAM on the protected system
  • Disk fragmentation on the affected disk of protected system
  • Excessive disk I/O (Possibly due to fragmentation)
  • Failed VSS transactions (Possibly due to the above problems)
  • Excessive amounts of data change since the initial snapshot of the volume

Resolution

Identify which volume is failing by navigating to the agent's logs.

To see agent logs:

  1. Navigate to the web UI on the device.
  2. Select the Protect tab.
  3. Click the Backup Logs link for the agent.
  4. Select Show Agent Logs.
  5. Use "CTRL+F" to search for "Error: 21".
  6. Find the error in the agent log:
Fri 19/01/18 4:22:07 am - Error reading from snapshot. Error: 21
Fri 19/01/18 4:22:07 am - Backup exception: Could not backup volume snapshots.
Fri 19/01/18 4:22:07 am - Unsuccessful DBD backup.
Fri 19/01/18 4:22:07 am - Destroy snapshots successful.
Fri 19/01/18 4:22:07 am - Query snapshots: 0 existing snapshots.
Fri 19/01/18 4:22:07 am - == Backup Failed ==

Troubleshooting will involve identifying the specific volume failing in the snapshot operation.

Follow these steps for verification:

  1. Identify the volume snapshot GUID for this backup attempt in the lines preceding the error in the agent logs:


Figure 1: The volume snapshot GUID in the agent log

  1. Search the backup log for the first line containing the volume snapshot GUID from the previous step. Identify and note the related volume GUID.


Figure 2: The corresponding volume ID

  1. To identify what drive letter this volume GUID is associated with, you can use one of the following methods.

NOTE  Note that methods 3b and 3c require terminal access to the Datto appliance, if you do not have this access and cannot log in to the protected agent for method 3a, please contact Datto Technical Support for assistance.

  1. On the protected system, open the Windows start menu.
    Type "CMD," then click the "Command Prompt" item that appears.
    In the prompt, type "mountvol." It will display each connected volume with it's GUID and Drive letter pairing. Note which drive letter matches the GUID you noted before and proceed to the next section titled "Resolving the Issue."
  2. Check the agent's '/datto/config/keys/[agentID].agentInfo' file for the volume GUID and its corresponding drive letter. Note which drive letter matches the GUID you noted before and proceed to the next section titled "Resolving the Issue."
  3. Alternatively, you can run snapctl update [agentID] and search for the volume GUID to find the corresponding drive letter:

Note which drive letter matches the GUID you noted before and proceed to the next section titled "Resolving the Issue."

Resolving the issue

  • Disk errors or Filesystem errors.
    • Check for disk errors by investigating the server's event logs at the time of the backup failure. Look for events containing the Volume GUID or the volume snapshot GUID for clues about disk errors.
    • If any are found, a chkdsk /r, or replacement of faulty hardware, may be required to repair the protected system.
  • Insufficient free space on affected disk of protected system.
  • Insufficient available RAM on protected system.
    • Make sure that the minimum system requirements are met in Getting Started With the Datto Windows Agent.
    • You will need to investigate if any processes are using excessive amounts of system RAM, or if a RAM upgrade would be required to meet the minimum requirements for backup.
  • Disk fragmentation on affected disk of protected system.
    • Windows disk optimizer can tell you the fragmentation percentage.
    • Utilities like Defraggler or MyDefrag can make visualizing and managing the fragmentation easier.
  • Excessive amounts of data change since the initial snapshot of the volume
    • Review the logs to see if the below error occurred. If you see this error, contact Datto Technical Support to help resolve this issue:
Snapshot not in a good state - State: 5 Error: 00000025. Deleting snapshot set